This is the advisory page for Identity Provider V3 releases. For the older V2 IdP or Service Provider advisories, refer to the V2 SecurityAdvisories page.

This page provides access to the complete history of Security Advisories released for the Shibboleth V3 Identity Provider and an "at a glance" table showing you which releases are vulnerable to what kinds of issues. If you're running a particular version, you can use this table to identify the issues that could affect your system and determine how urgent an upgrade is. In addition to the announce mailing list, you can "watch" this page for changes to keep abreast.

You can determine the exact version you're running based on the process log during startup.

If you would like to report an issue you believe is security related, you can do any of the following:

As always, sites are advised to use the latest stable release of any Shibboleth product. Refer to the ProductVersioning page for information about our support and versioning policies. The Home page identifies the specific versions recommended at a given point in time

This page only covers advisories affecting the V3 Identity Provider software. Other advisories are not listed here, but you can find the complete set of advisories inĀ this directory.

Obviously not all vulnerabilities are created equal, and the classifications in the matrices are general in nature, and are meant to point you to the relevant advisories to look into.

A particular version will typically be implicated by any advisories noted for it and for any newer versions above it in the tables.

Advisories noted for "All" versions should be reviewed by all deployers for relevancy to their deployment. Typically this indicates that an advisory is at least partly discussing issues that go beyond the scope of what the Shibboleth software can actually remediate and may affect the deployment as a whole. It does not in general refer to unfixed vulnerabilities in the Shibboleth software itself.

Identity Provider Vulnerability Matrix

The oldest IdP 3 version unaffected by fixable vulnerabilities is 3.3.2.

VersionEOLUser Data ExposureUser Data AccuracySession HijackingDenial of ServiceRemote ExploitAdvisories
3.3.2
XX



3.3.1Oct 2017XX


2017-05-18, 2017-10-04
3.3.0Mar 2017X



2017-03-15
3.2.1Nov 2016
X


2016-10-27
3.2.0Dec 2015
X



3.1.2Nov 2015
X



3.1.1Jul 2015
X



3.1.0Mar 2015
X
X
2015-03-26
3.0.0Mar 2015
X
X

Advisory List

DateTitleAffectsSeverityCVE
2017-10-04

LDAP Data Connector insecure when using default JVM trust

IDP < 3.3.2high
2017-05-18Default Kerberos configurations are unsafeAllhigh
2017-03-15

Design flaw can result in second-factor authentication bypass

IDP < 3.3.1high
2016-10-27

Collision in LDAP Data Connector result set cache

IDP >= 3.0.0, < 3.3.0critical
2015-03-26

Interrupted HTTP Connections Lead to Denial of Service

IdP >= 3.0.0, < 3.1.1high