Skip to end of metadata
Go to start of metadata
Icon

Version 3 of the Identity Provider is under active development. As such, this documentation is incomplete and also under development.

Below is the documentation available for version 3.0 of the Shibboleth Identity Provider. Documentation is split up in to two parts: documentation meant for individuals that are deploying and managing an Identity Provider and documentation meant for individuals that are developing custom extensions for the Identity Provider.

As a point of information for current and future deployers, the project has made the following platform/version decisions that may impact planning:

  • Java 7 (support for 8 is expected but not guaranteed since it's unreleased). NOT supporting Java 6 or earlier.
  • Servlet API 3.0 (this is required for the Spring Framework's current releases)
    • Use of 3.0 implies that some older containers (Tomcat 6, Jetty 7) won't be usable
  • No labels